Comandos routers [SP]


*NOMBRAR AL ROUTER 
router> enable
router# configure terminal
router(config)# hostname RouterA (nombra al router como)
RouterA(config)#
***************************************************
*CONFIGURAR CONTRASEÑAS “ENABLE SECRET” Y “ENABLE PASSWORD”
RouterA> enable
RouterA# configure terminal
RouterA(config)# enable secret contraseña * (configura contraseña Enable Secret)
RouterA(config)# enable password contraseña (configura contraseña Enable Password)
RouterA(config)#
***************************************************
*CONFIGURAR CONTRASEÑA DE CONSOLA * Es recomendable configurar Enable Secret ya que genera una clave global cifrada en el router.
RouterA> enable
RouterA# config terminal
RouterA(config)# line con 0 (ingresa a la Consola)
RouterA(config-line)# password contraseña (configura contraseña)
RouterA(config-line)# login (habilita la contraseña)
RouterA(config-line)# exit
RouterA(config)#
***************************************************
*CONFIGURAR CONTRASEÑA VTY (TELNET)
RouterA> enable
RouterA# config terminal
RouterA(config)# line vty 0 4 (crea las 5 líneas VTY, pero podría ser una sola. Ej: line vty 0)
RouterA(config-line)# password contraseña (contraseña para las 5 líneas en este caso)
RouterA(config-line)# login (habilita la contraseña)
RouterA(config-line)# exit
RouterA(config)#
***************************************************
*ENCRIPTAR CONTRASEÑAS
RouterA(config)#service password-encryption
**DESENCRIPTAR
RouterA(config)#no service password-encryption
***************************************************
*CONFIGURAR INTERFACES ETHERNET ó FAST ETHERNET * Tener en cuenta que la interfaz puede ser Ethernet o Fast Ethernet y que el número de interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el router.
RouterA> enable
RouterA# config terminal
RouterA(config)# interface fastethernet 0/0 * (ingresa al Submodo de Configuración de Interfaz)
RouterA(config-if)# ip address 192.168.0.1 255.255.255.0 (configura la IP en la interfaz)
RouterA(config-if)# no shutdown (levanta la interfaz)
RouterA(config-if)# description lan (asigna un nombre a la interfaz)
RouterA(config-if)# exit
RouterA(config)#
***************************************************
*CONFIGURAR INTERFACES SERIAL COMO DTE  * Tener en cuenta que el número de interfaz puede ser 0, 1, 0/0, 0/1, etc. Esto varía según el router.
RouterA> enable
RouterA# config terminal
RouterA(config)# interface serial 0/0 * (ingresa al Submodo de Configuración de Interfaz)
RouterA(config-if)# ip address 10.0.0.1 255.0.0.0 (configura la IP en la interfaz)
RouterA(config-if)# no shutdown (levanta la interfaz)
RouterA(config-if)# description red (asigna un nombre a la interfaz)
RouterA(config-if)# exit
RouterA(config)#
***************************************************
*CONFIGURAR INTERFACES SERIAL COMO DCE
RouterB> enable
RouterB# config terminal
RouterB(config)# interface serial 0/1 * (ingresa al Submodo de Configuración de Interfaz)
RouterB(config-if)# ip address 10.0.0.2 255.0.0.0 (configura la IP en la interfaz)
RouterB(config-if)# clock rate 56000 (configura la sincronización entre los enlaces)
RouterB(config-if)# no shutdown (levanta la interfaz)
RouterB(config-if)# description red (asigna un nombre a la interfaz)
RouterB(config-if)# exit
RouterB(config)#
***************************************************
*CAMBIE EL NÚMERO DE COMANDOS ALMACENADOS EN EL BÚFER DEL HISTORIAL
S1(config)#line console 0
S1(config-line)#history size 35
S1(config-line)#line vty 0 4
S1(config-line)#history size 35
***************************************************
CAMBIAR ‘IMAGEN’ DE ARRANQUE DE SWITCH
S1#show flash   *para poder verificar imagenes existentes
*Ejemplo
Directory of flash:/
    1  -rw-     4414921          <no date>  c2960-lanbase-mz.122-25.FX.bin
    3  -rw-     4670455          <no date>  c2960-lanbase-mz.122-25.SEE1.bin
    2  -rw-         616          <no date>  vlan.dat
*entrar en modo configuracion
S1(config)#boot system (nombre de la imagen)
S1(config)#end
S1#wr        *graba configuracion
S1#reload    *reinicia switch
***************************************************
?
  <1-99>      Session number to resume
  auto        Exec level Automation
  clear       Reset functions
  clock       Manage the system clock
  configure   Enter configuration mode
  connect     Open a terminal connection
  copy        Copy from one file to another
  debug       Debugging functions (see also ‘undebug’)
  delete      Delete a file
  dir         List files on a filesystem
  disable     Turn off privileged commands
  disconnect  Disconnect an existing network connection
  enable      Turn on privileged commands
  erase       Erase a filesystem
  exit        Exit from the EXEC
  logout      Exit from the EXEC
  mkdir       Create new directory
  more        Display the contents of a file
  no          Disable debugging informations
  ping        Send echo messages
  reload      Halt and perform a cold restart
  resume      Resume an active network connection
  rmdir       Remove existing directory
  setup       Run the SETUP command facility
  show        Show running system information
  ssh         Open a secure shell client connection
  telnet      Open a telnet connection
  terminal    Set terminal line parameters
  traceroute  Trace route to destination
  undebug     Disable debugging functions (see also ‘debug’)
  vlan        Configure VLAN parameters
  write       Write running configuration to memory, network, or terminal
***
***************************************************
*CONFIGURAR RIP
 ‘en modo enable>config’
Router(config)#router rip           (activa el protocolo RIP)
Router(config-router)#network 1   (assignar numero a la red en RIP)
Router(config-router)#network 192.168.0.0        (identifica la RED conectada)
Router(config)#no router rip     (desactiva RIP)
 ‘para ajustar los tiempos de update-invalid-holddown-flush respectivamente’
Router(config-router)#timers basic 30 180 180 240
 ‘para parar que emita broadcast a internet pero seguiendo escuchando los demas RIP’
Router(config-router)#passive-interface Fa0/0
 ‘para enviar actualizaciones en redes No Broadcast(frame relay) hay q decir al RIP
  para enviar en esta red en unicast’
Router(config-router)#neighbor XXX.XXX.XXX.XXX
  (XXX.XXX.XXX.XXX= direccion del “vecino”)
 ‘La version 2 de RIP soporta authentification, key mangement, route sumarization,
  classless interdomain routing (CIDR) y VLSMs.
  Por defecto el software recibe RIP version 1 y version 2 pero solo envia paquetes version 1.
  Se puede configurar que envie o reciba solo version 1 o version 2.’
Router(config-router)#version 2   (si solo queremos la version 1 cambiamos el 2 por el 1)
 ‘Se puede controlar las versiones de actualizaciones enviadas y recebidas en cada interface
  para mayor flexibilidad en el soporte de versiones’
Router(config-if)#ip rip send version 2
Router(config-if)#ip rip receive version 1
***************************************************
*Rip
NewYork(config)#interface fastethernet0/0
NewYork(config-if)#ip address 192.168.50.129 255.255.255.192
NewYork(config-if)#ip rip send version 1
NewYork(config-if)#ip rip receive version 1
NewYork(config)#interface fastethernet0/1
NewYork(config-if)#ip address 172.25.150.193 255.255.255.240
NewYork(config-if)#ip rip send version 1 2
***************************************************
*COMANDOS “SHOW”
Show ip protocols
show interface interface
show ip interface interface
show running-config
Show ip rip database
***************************************************
*OSPF
Router(config)#router ospf process-id
Router(config-router)#network address wildcard-mask area area-id
Router(config)#interface lookback 0
Router(config-if)#ip address 192.168.3.33 255.255.255.255
Rtr(config-if)# bandwidth 64
Rtr(config-if)# ip ospf cost 1562
***************************************************
*AUTENTICACIÓN SIN MD5
Router(config-if)#ip ospf authentication-key password
Router(config-router)#area area-number authentication
***************************************************
*AUTENTICACIÓN CON MD5
Router(config-if)#ip ospf message-digest-key key-id encryption-type md5 key
Router(config-router)#area area-id authentication message-digest
Router(config-if)#ip ospf hello-interval seconds
Router(config-if)#ip ospf dead-interval seconds
debug ip ospf events
–aumentar la prioridad para elegir un router DR
sw(config)#interface fasethernet 0/0
sw(config-if)#ip osfp priority 50
sw(config-if)#end
***************************************************
*EIGRP
Router(config)#router eigrp as-id
Router(config-router)#network 192.168.3.0
Router(config-router)#end
Router# show ip eigrp topology
eigrp log-neighbor-changes
resumen de rutas: router(config-router)#no auto-summary
***************************************************
*SWITCH
Switch# dir flash:
Switch#show flash
Switch#show vlan
***************************************************
*CREAR VLAN EN MODO BASE DE DATOS
Switch#vlan database
Switch(vlan)#vlan <vlan id> name <vlan name>
Switch(vlan)#exit
***************************************************
*CREAR VLAN EN MODO CONFIG-VLAN
Switch(config)#vlan <vlan id>
Switch(config-vlan)#name <vlan name>
Switch(config)#exit
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan <vlan id>
Switch#vlan database
Switch(vlan)#no vlan 300
Switch(config)#interface fastethernet 0/9
Switch(config-if)#switchport access vlan <vlan id>
Sw1#delete flash:vlan.dat
Sw1#erase startup-config
Sw1#reload
***************************************************
*INTERFACE WEB
Sw1(config)#ip http port 80
***************************************************
*VER LA TABLA MAC:
Switch#show mac-address-table (? Mas opciones)
Switch#clear mac-address-table
***************************************************
*ASIGNAR UNA MAC ESTATICA
•Switch(config)#mac-address-table static interface FastEthernet vlan
•Switch(config)#no mac-address-table static interface FastEthernet vlan
Seguridad de Puerto
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#switchport port-security ?(sale las opciones)
***************************************************
*LIMITAR LA CANTIDAD DE HOST POR PUERTO
1900:
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#port secure mas-mac-count 1
*2950:
Sw1(config)#interface fastETehernet 0/2
Sw1(config-if)#switchport port-security maximum 1
***************************************************
*CONFIGURACION DEL PUERTO QUE SE DESCONECTE CUANDO SE PRODUCE UNA VIOLACION DE SEGURIDAD
Sw(config-if)#switchport port-security violation shutdown
2900xl:
Sw(config-if)#port security action shutdown
***************************************************
*PONER IP A LA VLAN1
*CATALYST 2950
Sw(config)#interface Vlan1
Sw(config-if)#ip address 192.168.1.2 255.255.255.0
Sw(config-if)#no shutdown
Sw(config)# ip default-gateway 192.168.1.1
***************************************************
*CATALYST 1900
Sw(config)#ip address 192.168.1.2 255.255.255.0
Sw(config)# ip default-gateway 192.168.1.1
***************************************************
*ARCHIVOS DE CONFIGURACION
Sw# copy running-config startup-config
1900:
Sw#copy nvram tftp://tftp server ip add/destination_filename
***************************************************
*CONFIGURACION DE LA VELOCIDAD
Switch(config)#interface fastethernet 0/9
Switch(config-if)#duplex full
Switch(config-if)#speed 100
***************************************************
*CREAR EL TRUNK DEL SWITCH
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#end
2900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end
1900:
Sw(config)#interface fastethernet 0/1
Sw(config-if)#swicthport mode trunk
Sw(config-if)#swicthport trunk encapsulation dot1q
Sw(config-if)#end
***************************************************
*TRUNK EN EL ROUTER
Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown
Router(config-if)#interface fastEthernet 0/0.1
Router(config-subif)#encapsulation dot1q vlan-number
Router(config-subif)#ip address…….
router1#copy running-config tftp
***************************************************
*QUITAR UN PUERTO DE UNA VLAN
Switch(config)#interface fasethernet 0/9
Switch(config-if)#no switchport access vlan 300
***************************************************
*ELIMINAR UNA VLAN
Switch#vlan database
Switch(vlan)#no vlan 300
***************************************************
*SPANNING TREE
show spanning-tree
***************************************************
*CONFIGURACION DE VTP
switch#vlan database
switch#vtp v2-mode
switch(vlan)#vtp domain password
switch#vtp {client | server | transparent}
***************************************************
*COPIAR EL IOS A UN SERVER TFTP
Sw#copy flash tftp
2900: sw#copy flash:nombre_del_archivo tftp
***************************************************
*COPIAR IOS DESDE UN SERVER TFTP
Sw#copy TFTP flash
Sw# copy Start tftp
1900: sw#copy nvram tftp://numero-ip/name
Sw#copy tftp startup-config
1900: sw#copy tftp://numero-ip/name nvram
***************************************************
*RECUPERAR EL ACCESO AL SWITCH
1. Apagar el switch, Vuelva a encenderlo mientras presiona el boton MODE en la parte delantera del switch. Deje de presionar el boton MODE una vez que se apague el led de STAT
2. introducir los siguientes comandos:
flash_init
load_helper
dir flash:
3. rename flash:config.text flash:config.old
4. reiniciar el sistema original:
4.1 despues de entrar al switch hacer: rename flash:config.old flash:config.text
4.2 sw#copy flash:config.text system:running-config
4.3 Cambiar los password
***************************************************
*ACTUALIZAR EL FIRMWARE
Sw#show boot (muestra el archive de boteo)
Cambiar el nombre del archivo de la ios,con el commando #rename flash:nombre flash:Nuevo_nombre
Sw(config)#no ip http Server
Sw# delete flash:html/*
Extraer la nueva version del IOS
Sw#archive tar /x tftp://192.168.1.3/nombre_del_archivo.tar flash:
Sw(config)#ip http Server
Sw(config)#boot system flash:nombre.bin
***************************************************
Spanning-Tree
#show spanning-tree brief
Cambiar prioridad: ios 12.0 sw(config)#spanning-tree priority 1
sw(config)#exit
ios 12.1 sw(config)#spanning-tree vlan 1 priority 4096
sw(config)#exit
***************************************************
*CONFIGURAR VLAN
Sw#vlan database
Sw(vlan)#vlan 2 name Logistica
Sw(vlan)#vlan 3 name Licitaciones
Sw(vlan)#end
1900:
Sw#config terminal
Sw(config)#vlan 2 name VLAN2
Sw(config)#vlan 3 name VLAN3
***************************************************
*CONFIGURAR PUERTOS EN LAS VLAN
Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#switchport mode access
Sw(config-if)#switchport access vlan2
Sw(config-if)#end
***************************************************
*ELIMINAR EL PUERTO DE LA VLAN
Sw(config-if)#no switchport access vlan2
Sw(config-if)#end
1900:
Sw#conf term
Sw(config)#interface fastethernet 0/2
Sw(config-if)#vlan static 2
***************************************************
*PARA ELIMINAR UN PUERTO DE LA VLAN
Sw(config-if)#no vlan-membership 2
Sw#show vlan
Sw#show vlan id 2
1900: Show vlan-membership
Show vlan 2
***************************************************
*ELIMINAR UNA VLAN
Sw#valn database
Sw(vlan)#no vlan 3
Sw(vlan)# exit
1900: sw(confgi)# interface ethernet 0/7
sw(confgi)#no vlan 3
***************************************************
*ENLACE EN TRONCAL ISL
sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation isl
sw(Config-if)#end
enlace troncal 802.1q
2950: por defecto dotiq
sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk
2900:
sw(Config.)#interafce fastethernet 0/1
sw(Config-if)#switchport mode trunk
sw(Config-if)#switchport trunk encapsulation dot1q
***************************************************
*VTP , SERVIDOR Y CLIENTE
Sw# Vlan database
Sw(vlan)# vtp server
Sw(vlan)# vtp domain group1
Sw(vlan)# exit
Sw# Vlan database
Sw(vlan)# vtp client
Sw(vlan)# vtp domain group1
Sw(vlan)# exit
***************************************************
*RUTEO ENTRE VLAN
PONER EL ENCAPSULAMIENTO EN LAS SUBINTERFACES DEL ROUTER
(config-if)#interface fastethernet 0/0.1
(config-subif)#encapsulation dot1q 1 (1 es la vlan a la que esta)

One thought on “Comandos routers [SP]

  1. Pingback: Preboot Execution Environment (PXE) « Brain Knowledge

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s